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1.0 INTRODUCTION 
 
The system is designed to provide a simple and flexible solution for a wide range of general logging 
tasks including: 
 

Equipment location or ‘ownership’ tracking 
Safety inspections and maintenance logging 
Job tracking 
Logging of equipment to site 
Simple equipment loans  
Etc. 

 
Equipment tracking data collected using the OPN2001 may be easily downloaded to the system            
database via USB, to maintain an accurate record of both the current and historical equipment loca-
tions and statuses. 
 
Standard reports included with the system include current and historical location and status reports. 
The Current equipment location/status may also be exported from the system in Excel format or as a 
simple text file for processing and reporting by other systems. 
 
Equipment may be associated into groups or categories for reporting, and if required an optional 
‘Download Reference’ may be entered when loading the stored tracking data into the database. This 
download reference may be used for a wide range of functions including specifying an expected      
return date for equipment being sent out on loan. 
 
A barcode label printing facility is included as standard, allowing Equipment labels, Operator ID              
labels, Location labels and Status labels to be generated direct from the system database.                            
Alternatively barcodes can be generated from other systems as required. 
 
OPN-Logger is available with single or multi-user database. This User Guide relates to the single 
user database edition of OPN-Logger.  
 
 
 



1.0 INSTALLATION  
The system software and OPN2001 drivers may be installed as summarised below: 

Notes:   
 

• The .NET 2.0 Framework is a prerequisite of OPN-Logger.  

• Some aspects of the software installation may require administrative privileges 
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1.1 INSTALLING OPN-LOGGER FROM CD 
 
To install the OPN_LOGGER software from CD proceed as follows: 
 

1) Run the installer setup.exe from the system CD and follow the prompts. (Setup.exe will                   
 normally attempt to install the required .NET 2.0 Framework if not present on the PC) 
 

2) Run CRRedist2005_x86.exe to install components used by the software reports module 
 

3) OPN_Logger is now installed.  
 

4) Now run OPN-Logger and proceed as shown below to create the system database: 

2. Click Create Database 

3. Specify a location and name for the database file and click OK.  
The default location for the database is: 
C:\ProgramData\Electronic Reading Systems Ltd\OPN-Logger 

4. The database has been successfully 
created. Click OK to continue. 

5. Click Yes to make this the active database 

1. Click Tools > Options from the program menu bar  



2. Click Create Database 

3. Specify a location and name for the database file and click OK.  
The default location for the database is: 
C:\ProgramData\Electronic Reading Systems Ltd\OPN-Logger 

4. The database has been successfully 
created. Click OK to continue. 

5. Click Yes to make this the active database 
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1. Click Tools > Options from the program menu bar  

1.2 DOWNLOADING AND INSTALLING  OPN-LOGGER FROM ERS WEBSITE 
 
To download and install OPN-Logger from the ERS Website proceed as follows : 
 

1) From the OPN-Logger product page click Product Downloads from the black menu bar below 
the product description 

 
2) Download OPN-Logger Demo Install and OPN-Logger Demo Reports Install  
   
3) Run the downloaded OPN-Logger Demo Install file (OPN-Logger.msi) and follow the prompts. 

(Note that the downloaded msi installer will not attempt to install the required .NET 2.0 frame-
work if not already present on the PC. In this case contact ERS for a copy of the installation kit 
which includes the .NET 2.0 framework) 

 
4) Run the OPN-Logger Demo Reports Install file (CRRedist2005_x86.exe) to install                      
 components used by the OPN-Logger reports 
 
5) OPN_Logger is now installed.  
 
6) Now run OPN-Logger and proceed as shown below to create the system database: 
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1.3 LICENCING OPN-LOGGER 
After initial installation the software will run in demonstration/evaluation mode where the max.                  
number of records in the database will be limited. 
 

To licence the software for normal use click Help > Licence Management and proceed as follows: 

2. Click Change Licence 

3. OPN_Logger generates a random Keycode. 
Contact ERS for the relevant release code  

1. Click Help > Licence Management  
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1.4 INSTALLING THE OPN2001 DRIVERS 
To install the drivers for the OPN2001 run the Opticon Driver Installer (USB Drivers Installer.exe) 
from the system CD and proceed as shown below.  
Note: Do not connect the OPN2001 data collector onto your PC until after the drivers have been  
installed below 

1) Click Run 

2) Click OK  

3) Click OK  

4) Click OK  

5) Click OK. 
The OPN drivers are now installed  

1.4.1 CHECKING THE DRIVER  INSTALLATION 
The driver installations can be checked via the Windows Hardware Device Manager as follows: 

Connect the scanner to the PC and from the Windows Device 
Manager expand the Ports section. The scanner will be listed 
with a description similar to: 
 

Opticon USB Code Reader (1D) (COMxx) 

The Windows Device Manager may be accessed by right-
clicking My Computer then selecting Properties from the 
drop down menu.  
Go to the Hardware Tab and click Device Manager 

6) Connect the OPN2001 to the PC. The Windows 
Found New Hardware wizard will automatically com-
plete the installation of the device. This may take a 
few moments 
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1.5 SYNCHRONISING THE OPN2001 REAL-TIME CLOCK 
 
The real-time clock in the OPN2001 will be automatically synchronised to the PC clock when                   
connecting to OPN-Logger to transfer data. 
 
Since the transaction date and time is used by OPN-Logger to determine an item’s latest Location or 
Status we make the following recommendations: 
 
1) Before using the system connect each OPN2001 to OPN-Logger and click Transfer Data  to                       

initialise the clocks (see Section 4.0 - Downloading the Data Collectors) 
 
2) In normal use the data collectors will be regularly synchronised during the download process. 
 If a data collector has not however been used for an extended period of time it may be  
 advisable to synchronise its clock by connecting to OPN-Logger and clicking Transfer Data 
 
3) After ad hoc regional time changes (eg: BST) make sure the data collectors are                        
 again re-synchronised to the correct time before proceeding to scan items. Failure to do this 
 will log items with the incorrect date/time stamp until the terminal is subsequently downloaded 
 and the clock is synchronised.  
 (In the majority of cases this will have no detrimental effect however if an item is scanned into 
 a location before being synchronised to the ad hoc time change, and is then scanned to a            
 different location shortly after synchronisation, the ad hoc time change could result in the 
 wrong record being used when reporting the latest location for the item). 
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2.0 OPN_LOGGER DATABASES 
OPN_Logger incorporates a number of internal databases as summarised below.   
 
 OPERATORS - A database of operator names may optionally be created in order to track the                   
 operators performing the logging if required 
 

 ITEMS - A database of the items being logged may be maintained including Item description 
 and up to 4 additional fields (Note: The titles for the additional fields are user configurable - 
 see section 2.3 below) 
 

 LOCATIONS - A database of location descriptions may be maintained. These will be the                   
 locations to which items will be logged. 
 

 STATUS CODES - a status code may also be associated with each item being logged. This 
 might for example indicate the condition of the item, or flag that the item requires calibration or 
 repair work etc.  A database of status code descriptions may be maintained as required. 
 
In addition OPN_Logger includes a Transactions database which is used to hold the tracking data 
downloaded from the data collectors. (See Section 4.0 below) 
 
The Operators, Items, Locations and Status Codes databases may be initialised by file import, or by 
manual editing via the PC keyboard (See sections 2.1 - 2.3 below). 
 
2.1 IMPORTING OPERATORS, LOCATIONS, ITEMS AND STATUS CODES 
To import details of Operators, Locations, Items and Status codes proceed as shown below. (Note: 
Formats for the import data files are summarised in APPENDIX 2 below) 

1. Click File > Import from the program menu bar and 
select the type of file to be imported from the list 

2. Browse to the location where the file is stored 
and click Open. 

3. The relevant database will be initialised with the data imported 
from the file. Note: The import will overwrite the database. 



2.3 CONFIGURING THE ITEMS DATABASE ADDITIONAL DATA FIELDS 
The items database includes the barcoded Item ID and description together with 4 additional data-
base fields.  
These additional fields may be used as selection criteria when configuring a set of data for reporting. 
For example an additional field might be used to group equipment of a similar type together for  
maintenance or safety checking purposes  
 

The titles of these additional fields are user configurable, as follows: 

2.2 MANUALLY EDITING THE SYSTEM DATABASES 
The system databases may also be initialised or edited via the PC keyboard as follows: 

1. Click Edit from the program menu bar and select the database to be           
edited from the list (operators, Locations, Items or Status Codes) 
Note: The stored transactions may also be edited - see section 4.1 below 

2. To add a new record into the database click Add New.                         
Alternatively highlight a record and click Edit to amend the record, or 
Delete to erase the record from the database. 

1. Click Tools > Options from 
the program menu bar  

2. From the Additional Fields tab enter the titles 
for the additional fields, as required 
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3.0 LOGGING ITEMS 
The OPN2001 data collector may be used to track item locations and log item statuses by scanning                     
barcodes as shown below: (Refer also to Appendix A  below for details of barcode data formats) 
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Operator Log-on  
required? 

Scan Operator ID 
Barcode 

Scan Item               
Barcode 

Item Location 
required? 

Status Code  
required? 

Scan Status code 
Barcode 

1. If required the operator performing the logging can be logged by scan-
ning an Operator ID. Note: There is no ‘Logoff’ function - an operator will 
automatically be logged off if another operator logs on, or after the data 
collector has been downloaded.  

3. The item barcode will be scanned  

2. If the item is being logged to a location the relevant Location barcode 
will now be scanned. This is optional and is only required if booking 
items to a location 

4. One or more Status codes may be attached to the item if required. 
These are optional and are only required if the item status is to be 
logged. 

Note: Scanned data will automatically be date/ time tagged and stored in the data collector for subsequent downloading to the 
OPN_Logger ‘transactions‘ database (see section 4.0 below). 

Scan Location 
Barcode 

Log another item 
at this location ? 

Start logging a 
new Location ? 

Log another 
Status Code ? 

New Operator ? 

Yes 

Yes 

Yes 

Yes 

Yes 

Yes 

Yes 

No 

No 

No 

No 

No 

No 

No 

4. Depending on the requirement the operator may now: 

• Scan another status code against the item 

• Scan another item to the current location 

• Scan a new Location code  
 

Alternatively a new operator may ‘Logon’ by scan an Operator ID 



4.0 DOWNLOADING THE DATA COLLECTORS 
To download stored data from the data collectors proceed as follows: 
 

Note: The Transfer Data facility will automatically synchronise the OPN2001 real-time clock. Before 
using the data collectors we therefore recommend using the Transfer Data function to ensure the all 
the devices are synchronised and set to the correct time 
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1. Connect the data collector to a suitable USB port 
on the PC and click Transfer Data 

4. OPN_Logger synchronises data collector to PC Clock 

4. Download successful. The data collector may be disconnected.                                                                            
Note: stored data will automatically be cleared from the data col-
lector after a successful download. 

2. Click to enable entry of a download reference, if required. This 
Reference will be attached to the data downloaded from the 
OPN2001 and may be subsequently used as a selection criteria 
when reporting. 
If using OPN_Logger to regularly audit asset locations, the 
download reference can for example be useful in identifying             
assets which have not been scanned during the current audit.  

3. OPN_Logger connects to the data collector 
and downloads stored data. 

5. enter a download reference (if required) 



4.1 EDITING THE DOWNLOADED TRANSACTIONS 
The downloaded transactions may be edited or new transactions manually entered if required, as 
shown below:  
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1. Click Edit > Transactions from the program menu bar  

2. To add a new record into the database click Add New.                         
Alternatively highlight a record and click Edit to amend the record, or 
Delete to erase the record from the database. 

Note: The Serial No. of the data collector used to log the item is also stored in 
the transactions database.  
This may be used as part of the data selection criteria when running reports but 
is otherwise not used by the system.  
The device serial no. is optional when manually adding or editing transactions. 

3. Enter or amend the relevant transaction details 
and click OK to update the database 
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5.0 RUNNING REPORTS 
A selection of standard reports are incorporated into the system. To run reports proceed as follows: 

1. Click Reports 

2. Select the report type required from the 
list, and selection criteria for the data. Click 
Run Report to generate the report  

3. The report is generated. 
 

Note: 
 

• Data records which have been manually entered or edited will be highlighted 
with an asterisk in the left hand column. 

 

• If multiple Status codes have been entered against an item only the last Status 
code entered will be shown in the Current Locations report. In this case the 
status code will be prefixed by an asterisk. Run the Current Status report to view 
all the Status codes for that location. 
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6.0 BARCODE PRINTING 
OPN_Logger includes a facility to print item and location barcodes using the Toshiba B-EV4T desk-
top label printer. This option may be used to generate 70mm x 32mm self adhesive paper or polyes-
ter labels including (where necessary) the relevant formatting characters as summarised in Appendix 
1 below. 
 

To print barcoded labels click Tools > Barcode printing and proceed as shown below: 

3. Use the search facility to display a specific record as 
required, or use the * wild card to display all records 
 

Highlight the record(s) to be printed, or click the Select All 
box to print all records. 

4. Specify the no. of copies required 
and click Print to generate the labels 

The label printing option works with the B-EV4T               
thermal label printer with 70mm x 32mm paper or 
polyester labels 

2. Configure the format of the Labels. Use the relevant drop down 
list to select up to 4 lines of data from the OPN-Logger database 
for the labels. Once configured this format will remain as default 
until subsequently changed. 
 

In this example an item label has been configured to include the 
item code (as a code39 barcode), the item code (as text) plus the 
item Description. The 4th line in this example hasn’t been used. 

1. Select type of label to be printed 
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7.0 EXPORTING THE TRANSACTIONS 
The transactions relating to the latest location and status may be exported from OPN-Logger in text 
or Excel format. 
To edit the transactions proceed as follows: 

1. Click File > Export > Current Locations/ Status 

2. Specify the location, name and file type for the 
exported data file and click Save to generate the file. 
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APPENDIX 1   BARCODE DATA FORMATS 
OPN_Logger allows items to be associated with a Location Code and/or various Status codes. In 
addition the system allows the Operator performing the logging to be identified using an Operator ID. 
 

In order to distinguish the different codes and IDs OPN_Logger defines a specific data format for    
Location codes, Status codes and Operator IDs as summarised below. 
 

If using the barcode printing facility in OPN_Logger these formats will automatically be handled by 
the software as required (see Section 6.0 above). These formats will however need to be considered 
if using other software packages to generate the Location and Status Code barcodes. 
 
 
LOCATION CODES 
Location Codes must be preceded by a + symbol. This is used to identify the barcode as a ‘Location’ 
and will be automatically stripped by the system before the data is stored in the database. 
For example the Location LOC001 should coded as +LOC001: 

STATUS CODES 
Status Codes must be preceded by a % symbol. This is used to identify the barcode as a ‘Status’ 
and will be automatically stripped by the system before the data is stored in the database. 
For example the Status Code ERS021 should coded as %ERS021: 

EXAMPLE LOCATION 

OPERATOR IDs 
Operator IDs must be preceded by a . symbol. This is used to identify the barcode as an Operator ID 
and will be automatically stripped by the system before the data is stored in the database. 
For example the Operator ID 1001 should coded as .1001: 

OPERATOR 1001 

STATUS ERS001 

ITEMS 
Barcodes without any of the above leading characters will be identified as Item codes. 
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APPENDIX 2  FILE FORMATS FOR IMPORT FILES 
The formats for the imported data files are summarised below: 
 
OPERATORS FILE - The Operators data file includes the Operator ID and name as follows: 
 

  [OP ID] , [Name] [cr.lf] 
Where 
  [OP ID] is the barcoded Operator ID 
      ,        (comma) is used as a delimiter 
  [Name] is the operator name 
  [cr,lf]     are the Carriage return and line feed characters 
 

For example: 
  10004,John Smith 
  10005,Robert Stone 
  30055,Amanda Johnson 
  M025,Peter Piper 
 
 
LOCATIONS FILE - The Locations data file includes the Location ID and description as follows: 
 

  [LOCATION ID] , [Description] [cr.lf] 
Where 
  [LOCATION ID] is the barcoded Operator ID 
      ,                     (comma) is used as a delimiter 
  [Description]     is the Location description 
  [cr,lf]                 are the Carriage return and line feed characters 
 

For example: 
  LOC001,Entrance Hall 
  LOC002,Secure Stock Room 
  ACM001,Project ACM001 
  C000X,Customer X 
 
 
ITEMS FILE - The Items file includes the Location ID and description as follows: 
 

  [ITEM ID] , [Description] , [Field 1] , [Field 2] , [Field 3] , [Field 4] [cr.lf] 
Where 
  [ITEM ID]                 is the barcoded Item ID 
      ,                           (comma) is used as a delimiter 
  [Description]            is the item description 
  [Field 1]R [Field 4]  are the optional additional data fields (see section 2.3 below) 
  [cr,lf]                        are the Carriage return and line feed characters 
 

For example: 
  IT001,Office Chair Type 1,Blue,Large,23kg,1 
  IT002,Office Chair Type 2,Red,Large,23kg,1 
  IT003,Office Chair Type 3,Blue,Medium,21kg,1 
 
 
STATUS CODES FILE - The Status Codes file includes the Status Codes and descriptions as fol-
lows: 
 

  [STATUS CODE] , [Description] [cr.lf] 
Where 
  [STATUS CODE]     is the barcoded Status Code 
      ,                           (comma) is used as a delimiter 
  [Description]            is the status description 
  [cr,lf]                        are the Carriage return and line feed characters 
 

For example: 
  SC002,Unlocked Door 
  SC003,Broken Window 
  SC005,Misssing Light 
  SC006,Missing Chair 
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APPENDIX 3 - HINTS & TIPS 
 
3.1 USING OPN-LOGGER TO TRACK EQUIPMENT LOANS 
OPN-Logger may be used to provide a simple means of tracking equipment and assets which are 
sent out on temporary loan, for example: 
 

• Equipment loaned to clients or personnel on a temporary basis 

• Equipment sent to site or installation purposes or temporarily booked to specific Projects 

• Etc. 
 
In this case the following ideas may be of assistance: 
 
1) Using the Download Reference to specify an Expected Return Date: OPN-Logger can be 

configured to prompt for entry of an optional Reference code when downloading the stored 
tracking data from the OPN20001 Data Collector.  

 Assuming that the Location, Client or Project etc. to which the equipment is being booked will 
 scanned into the OPN2001 data collector as a barcoded ‘Location’ Code, the Download                
 Reference could be used to specify an expected return date for the items if required. 
 
2) Using an Additional Database field to identify Equipment Part Nos: OPN-Logger uses a 

unique barcode ID for each item of equipment in order to track the location and history of               
individual items. even if the stock includes multiple.  

 If the Part No. of each item in the Equipment database is included as one of the available 
 ‘Additional Data fields’ the system may then be used to generate a list of all items for a specific 
 part no. including the current ‘availability’ (eg: showing whether the item is currently in stock or 
 at a different location). Where the Download Reference has been used as above to hold a re
 turn date this will also be shown where relevant). 
 
3) Reserving Items: Items of equipment which are required for projects in the very short term 

may be booked to a ‘Reserved’ Location, and the Download Reference used to indicate the 
Project/ Client ID and ‘required’ date if required. The current status for these items will then 
show as reserved in order to prevent allocation elsewhere. 

 Note: We do not recommend this technique for logging future reservations. 


